Issue
OutOfMemory error makes the respective JAVA application unavailable.
Root Cause
This issue occurs when a JAVA application runs out of HEAP memory.
Resolution
Locate and open the JBoss logs in a text editor program. If you are experiencing this issue, you should be able to find the following error:
Caught unexpected Throwable: java.lang.OutOfMemoryError: Java heap space
Follow the steps below if you see the error:
- Locate standalone.conf file. Path: <JBoss Installation Directory> > standalone > bin > standalone.conf
- Open it in a text editor.
- Modify the specific line allocation configuration to the following:
-Xms1024M -Xmx2048M -MaxPermSize=512M
- Restart JBoss to apply the new configuration.
- Monitor the application for a while and see if the issue persists.
- If the issue persists, please collect heap and thread dump while the issue occurs.
- Contact our support team and attach the collected heap and thread dump into the support ticket.
Comments
0 comments
Please sign in to leave a comment.